Why did I not receive the security code? Why the code is invalid?

  • September 30, 2022
  • min read

For your security we have implemented the Two Factor Authentication (2FA) practice as a standard for the access to your account.

This means that each time you attempt to access to your account on my.emsisoft.com with your password, you will also receive a security code in your email address, or Authentication App on your phone.

The security code is sent automatically by our servers and it only takes a few seconds until you can see the security code in your inbox. If you didn’t receive the security code, the most likely reasons are:

Email Routing Problems.

Sometimes, mailservers have technical problems which may result in a long delay or missed delivery of the emails. Try to send a test email to yourself to ensure the email address is working correctly or you can also click on “I haven’t received that email within 2 minutes” button for a second send attempt.
Please make sure to use only the last code you received, in case of double delivery.

I haven't received the code in 2 minutes

Spam/Junk Mail Filter Settings

Check your spam (junk mail) filter for [email protected] or contact your internet service provider if the email was wrongly filtered. The more popular free email providers such as Hotmail, Yahoo, Verizon or GMX use very restrictive spam filters which mark most automatically sent emails as spam. Also, please note that if you use a spam filter that requires a manual confirmation by the sender (sometimes called a challenge/response system), it will not work with our helpdesk system.

Wrong Email Address

Please make sure that you carefully type your email address, and review it for typos before submitting. In our experience, after spam filters, simple typos are the most common reason for a missing password or registration mail.

Best practices

We recommend to add also the Authentication App as an option for your Two Factor Authentication.
Log into my.emsisoft.com and click on “MyAccount” in the top-right corner

MyAccount

From there, scroll down and find the option Multi-Factor Authentication.
You can choose the option Email & Authenticator, which will prompt the instructions to enable the Authenticator App.

This will allow you use either the code delivered via email or the one that appears in your Authenticator app.

 

I typed the code, although it says that the code is invalid. What should I do?

It may happen that even with a security code you may not be able to access. This rare occurrence is due to the use of the incorrect (old) code or because you closed the login window/tab in your browser. Here’s what to do:

  1. First, delete all existing security code emails to avoid confusion. They are single-use only for the most recent login attempt and chances are that you are not using the last one generated by our system.
  2. When you log into my.emsisoft.com , after supplying the email address and password, and being presented with a request for the security code we email to you, it is important to NOT navigate away from the web page that is requesting the security code.
  3. If you do navigate away from or close the page, the security code that was sent will not work. A new one is generated with every login attempt, and only that one will work for that login attempt.

If you’re not sure how to use web browser tabs to switch between email and the security code request page, here’s how to use tabbed browsing.

No votes yet.
Please wait...

Similar topics